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Creating Accessible PDF Documents 
with Adobe® InDesign® CS4

Introduction
Can you read this document with your eyes 
closed? For people with visual disabilities, 
that’s a challenge they’re faced with everyday. 
Fortunately, you can use Adobe InDesign CS4 
to make an accessible PDF document. You do 
this by adding “under the hood” features that 
don’t affect the look of your pages, but do allow 
screen readers and other assistive devices to 
function properly.

This is important because many govern-
mental agencies now require that all electronic 
documents be made accessible (often called 
“Section 508,” based on a U.S. Federal law 
passed in 1998). Similarly, due to other laws 
and policies, school textbooks and other educa-
tional materials must often be made accessible, 
too.

But even if you aren’t required to make 
your documents accessible, there are good 
reasons to do so. For example, you can view an 
accessible document easier on a wide variety of 
readers, such as mobile devices, because acces-
sible documents can reflow on small screens.

If you already have a document in PDF for-
mat, you can add accessibility features in Adobe 
Acrobat Pro. However, it is far easier to add 
these features from within InDesign before you 
make the PDF. More importantly, if you have to 
edit the document and create a new PDF, you 
won’t have to redo all the work you had done in 
Acrobat.

In this document we’ll take a look at what is 
required in an accessible PDF document, how 
to perform those tasks in InDesign, and which 
follow-up tasks you will want to perform in 
Acrobat. 

Overview of Required Elements
An accessible PDF file should include these 
elements:

 » Logical reading order. Does the document 
make sense when it is read aloud by a screen 
reader, or reflowed for a mobile device? This 
is handled by careful tagging of each story, 
heading, and paragraph.

 » Alternate Text Descriptions for Non-Text 
Elements. Can visually-impaired people or 
readers that do not display images under-
stand what each picture represents? This is 
handled by adding “Alt” tags to each image.

 » Tagging Artifacts. Background images, page 
numbers, and other objects that are not 
relevant to a screen reader or reflowed text 
should be tagged as “artifacts.”

 » Metadata. While metadata isn’t required, it’s 
helpful if your document includes informa-
tion about itself, such as title, author, key-
words, and language.

 » Hyperlinks. Any text that appears to be 
a hyperlink (such as an website address) 
should be tagged with an actual link. Simi-
larly, you should add bookmarks to jump 
quickly to each section in the document.

Note that interactive forms require addi-
tional accessibility features. However, forms, 
which must be built in Adobe Acrobat Pro or 
LifeCycle Designer, are outside the scope of this 
document.
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Tagging Text
Most word-processing documents are linear—
they begin a the top of the page and end at the 
bottom. However, pages built in InDesign are 
often non-linear: A magazine article’s headline 
may be at the bottom of the page, or two or 
more distinct articles may appear side-by-side 
on a single page. To make these documents 
accessible, it is critical that you specify a read-
ing order so that a screen reader or mobile 
device can interpret the page properly.

To specify reading order, you must tag 
each story and paragraph with the Tags panel 
(choose Window > Tags). All tagged text 
appears listed in the Structure pane (choose 
View > Structure > Show Structure). 

These tagging features are the same as those 
used for XML import or export. However, you 
do not need to know much about XML in order 
to tag a document for accessibility, and even a 
beginner can quickly learn to tag a document.

Note: If your document is already tagged for 
XML import or export, it may be ready to cre-
ate an accessible PDF file. Unfortunately, the 
XML tags you have used may not match the 
recommended tag names, so you may need to 
rename them in the Tags panel before creating 
the PDF. Alternately, you can use the Role Map 
feature in Acrobat Professional to rename the 
tags (see “Working in Acrobat Pro,” later in this 
document).

Creating Tags
Before you tag your document, you must create 
named tags in the Tags panel. InDesign can 
automatically add most of the tags you will 
need: choose Add Untagged Items from the 
Structure pane menu (Figure 1). When you 
choose this, about a dozen tags will be added 
to the Tags panel, including H1, H2, Story, 
Figure, and Artifact (Figure 2). You will 
be using these tags to identify elements in your 
document.

The Add Untagged Items feature also tags 
all your document’s text and graphic frames 

Figure 1. Choosing Add Untagged Items from 
the Structure pane menu.

Figure 2. The Tags panel, with the default set of 
tags, created by Add Unnamed Items.

for you. This is very helpful, as it speeds up the 
tagging process.
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If your document includes tables, you 
should create several additional tags in the Tags 
panel, named Table, Cell, and TH. You can 
create a tag by choosing New Tag from the Tags 
panel menu, or clicking the New Tag button in 
the panel and then naming the tag.

Tip: You can import tags already created in 
another InDesign document by choosing Load 
Tags from the Tags panel.

Applying Tags to Text
Once you have created a set of tags, you can 
apply them to the document. As noted earlier, 
choosing Add Untagged Items applies the Story 
tag to each text frame, and the Figure tag to 
each graphic frame in your document. If you 
later add a new frame, you can tag it by select-
ing it with the Selection tool and then clicking 
the Story (for a text frame) or Figure (for a 
graphic frame) tag in the Tags panel.

The next step is to tag individual para-
graphs inside each story. This is important 
because the PDF itself doesn’t really understand 
the concept of a paragraph or how a headline is 
different than body text. In an untagged PDF, 
it’s all just letters on a page.

Fortunately, if you have used paragraph 
styles throughout your document, you can 
tag all your paragraphs quickly by choosing 
Map Styles to Tags from the Tags panel menu 
(Figure 3). In the Map Styles to Tags dialog box, 
click on each paragraph you have used in the 
document and then choose a corresponding tag 
from the pop-up menu that appears in the right 
column. For example, all body text paragraphs 
can be mapped to the P tag; a title could be 
mapped to the H1 tag; a subhead might be 
mapped to the H2 tag; and so on. (There are no 
rules for which of the standard tags you should 
use, but it is a good practice to be consistent 
across all your documents, when possible.)

Tip: If some of your paragraph style names 
already match your tag names, you can click 
the Map By Name button to match the two 
automatically.

Figure 3. The Map Styles to Tags dialog box

When you click OK, InDesign tags all your 
styled paragraphs based on the settings in the 
dialog box. You can see this by clicking the 
triangle next to one of the Story elements in 
the Structure pane—you should see a series of 
P tags and other tags. You can double-click one 
of these elements to highlight the paragraph in 
the document window.

If you have not used paragraph styles in 
the document, you can still use the Map Styles 
to Tags dialog box to map the Basic Paragraph 
Style (which is, by default, applied to all para-
graphs) to the P tag. Then you can change the 
tag for an individual paragraph in the docu-
ment—such as a subhead—by choosing the 
Type tool, clicking once in the paragraph (so 
that the cursor is flashing), and then clicking a 
tag in the Tags panel. 

Applying Tags to Tables
Documents that contain tables may require 
several extra steps. When you chose Map Styles 
to Tags, InDesign tagged the text inside each 
cell along with the rest of the document. At the 
same time, InDesign automatically added two 
additional tags to the Tags panel: Table and 
Cell. It then applied those tags to each table 
and cell in the file (which you can see in the 
Structure pane; Figure 4).

However, if your tables contain header 
rows, you should tag those separately after 
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Figure 4. The Structure pane, after mapping 
style to tags. Note that a Cell tag is underlined, 
indicating that this cell is currently selected on 
the document page.

exporting the PDF file (see “Working in Acro-
bat Pro,” later in this document).

Applying Tags to Lists
Adobe InDesign currently exports all list items 
as regular paragraphs, even if the paragraphs 
are tagged with <L> or <LI> in the Tags panel. 
Therefore, you will need to fix list items in 
Acrobat Pro (see “Working in Acrobat Pro,” 
later in this document). However, to simplify 
that work, you should ensure that all bulleted 
and numbered paragraphs are assigned an 
appropriate paragraph style in InDesign.

Special Considerations
There are several special considerations to keep 
in mind when tagging objects in your docu-
ment:

 » While you can tag text or images on a master 
page, only one instance of the correspond-
ing element appears in the Structure pane, 
regardless of how many times the item 
appears on document pages. However, if 
you manually override a master item, the 
item will appear as a separate element in the 
Structure pane.

 » Footnotes cannot be tagged in InDesign 
as separate paragraphs. They do appear, 
however, in tagged PDF documents, auto-
matically tagged with the name of their 
paragraph style.

 » You cannot tag a group of objects. You can 
tag a frame inside a group by selecting it 
with the Direct Selection tool first.

Ordering Tags
Look closely at the order of the articles and 
stories in the Structure pane—click on the 
triangles next to the structure elements to open 
them if necessary. The order you see here may 
not match the order you would expect or want 
if your document were read aloud. For exam-
ple, a story’s heading may appear after the story. 

When you use the Add Untagged Items 
feature, InDesign creates the structure based on 
the order in which you created each text frame. 
However, you can easily reorder the structure, 
so that someone with a visual impairment will 
hear it as you intended (or a mobile device will 
display it in the proper order).

To find a specific text frame in the Struc-
ture pane, select it on the document page; the 
Structure pane underlines the name of the 
associated element. Then you can drag it to a 
new location in the Structure pane. 

However, take care when dragging struc-
ture elements—it may change the appearance 
of your document in unwanted ways. Dragging 



Creating Accessible PDF Documents with Adobe InDesign CS4 9

Figure 5. Reordering text elements by drag-
ging in the Structure pane. Here, each Story is a 
different text frame and the heading “Introduc-
tion” needs to be moved before the paragraph. 
Note that choosing Show Text Snippets from the 
Structure pane menu enables you to see the first 
few words of the paragraph, which helps when 
reordering elements.

a Story element from one position to another 
should be okay, but dragging a P element (a 
paragraph inside a story) actually moves that 
paragraph from one position to another.

Tip: Watch where you “drop” the element when 
dragging it. Dragging an element on top of 
another element places it inside that element, 
which is often undesirable when reorder-
ing. Instead, look for a thick black horizontal 
line indicating that the element will be placed 
before or between elements. The width of the 
line determines the level within the structure 
hierarchy (Figure 5).

Tagging Graphics
Images in your document are no use to some-
one with a visual impairment unless they 
contain an alternate text description that can 
be read by a screen reader. Alternate text is also 
visible on screen in Acrobat when the viewer 
hovers the cursor over an image—useful in 
many documents.

To add alternate text, first make sure the 
graphic frame is tagged with a Figure tag.  
The Add Untagged Items feature does this 
automatically. However, if you later add a new 
image to your document, you can easily tag it 
by selecting it with the Selection tool and click-
ing the Figure tag in the Tags panel.

Next, while the graphic frame is selected, 
find it in the Structure pane, where it appears 
underlined. Choose New Attribute from the 
Structure pane menu. Alternatively, you can 
right-click (or Control-click with a one-button 
mouse) on the Figure tag in the Structure pane, 
and choose New Attribute from the context 
menu. In the New Attribute dialog box, type 
Alt in the Name field, and type your alternate 
text description in the Value field. 

When you click OK, the alternate text 
appears as an attribute of the Figure element. 
(Click the triangle next to the word Figure to 
display its attributes; Figure 6)

Tip: If your graphic has a caption, you may also 
want to create a new Caption Tag in the Tags 
panel and apply it to that paragraph. 

Figure 6. Adding an Alt attribute to a Figure tag 
in the Structure pane.
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Tip: If it’s important to maintain the position of 
a graphic relative to some text in your docu-
ment, consider making the graphic an inline 
or anchored object in the text. Otherwise, the 
image may display out of order, even if you 
place it the correct order in the Structure pane.

Applying Tags to Artifacts
Background images, running headers, page 
numbers, and non-essential information should 
be tagged with the Artifact tag so that they 
can be ignored by screen readers or when the 
PDF is displayed in Reflow mode (such as on 
a mobile device). To define an object as an 
artifact, click on it with the Selection or Direct 
Selection tool and then click Artifact in the 
Tags panel.

Note that only objects—such as text frames 
or graphics frames—can be tagged as artifacts. 
You cannot tag individual paragraphs inside a 
story as an artifact. Also, you do not need to tag 
empty frames or paths, as they are automati-
cally ignored by screen readers.

File Information and Metadata
Metadata is information about a document, 
such as its title, author, and copyright informa-
tion. It is a good practice for all Acrobat PDF 
files to contain document metadata, but this is 
especially important for accessible documents 
and any document that will be distributed 
electronically. 

You can insert metadata about your PDF 
file from within InDesign by choosing File > 
File Info. While you are technically adding the 
metadata to your InDesign file, this informa-
tion is passed through to any PDF file you 
export, saving you from having to add it later in 
Acrobat.

The File Info dialog box offers many meta-
data options (Figure 7), but the important ones 
for accessible documents are: Title, Author, 
Description, and Keyword. The Description 
field equates to the Subject field in Acrobat.

Figure 7. The File Info dialog box lets you add 
XMP metadata that can be read in the exported 
PDF file.

Tip: If you expect to use the same File Info set-
tings multiple times, consider choosing Export 
from the Templates pop-up menu at the bot-
tom of the dialog box. Later, you can add the 
settings to a new document by choosing Import 
from that same pop-up menu.

Bookmarks and Hyperlinks
When creating any Acrobat PDF document 
designed to be viewed electronically, you 
should consider adding hyperlinks and book-
marks. These are both particularly important in 
accessible documents, because they allow easier 
navigation.

For example, consider a document that 
contains footnotes or instructions such as 
“Continued on page 21.” You can use the Hyper-
links panel in InDesign to create text anchor 
links so that a disabled person can follow the 
story easily. You can also use the Hyperlinks 
panel to create cross-references (such as “see 
page 3” or “see Figure 6-15”). These links are all 
made “live” in the final PDF file.

Similarly, if your document contains links 
to external files (such as to a website), be sure 
to assign links to them in the Hyperlinks panel. 
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Bookmarks can be added with either the 
Bookmarks panel or by creating a table of 
contents for your document (Layout > Table of 
Contents).

Creating the Acrobat PDF File
After you have tagged your InDesign docu-
ment and added hyperlinks, bookmarks, and 
metadata, it’s time to export as an Acrobat PDF 
file. It is imperative that when creating the PDF 
file you use File > Export rather than creating 
the PDF via the Print dialog box. Using the 
Print dialog box to make the PDF will omit all 
the structure and work you have done to make 
your file accessible.

After you choose File > Export, choose 
Adobe PDF from the Format pop-up menu and 
give the file a name. When you click Save, the 
Export Adobe PDF dialog box appears, offering 
a number of options for creating your PDF file 
(Figure 8).

Accessible documents should be saved 
with the Compatibility pop-up menu set to 
Acrobat 5 or later. The following checkboxes 
should be selected: Create Tagged PDF, Opti-
mize for Fast Web View, Bookmarks, Hyper-
links, and Interactive Elements. In most cases, 
you will also want to select View PDF after 
Exporting so that the file will open in Adobe 
Acrobat.

Tip: If you have added more than one docu-
ment to a book panel, you can export the entire 
book as a single PDF file. To do this, select the 
documents you want included, then choose 
Export PDF from the book panel menu.

Tip: You may want to use the options in the 
Security pane of the Export Adobe PDF dialog 
box to restrict how someone can use the PDF 
file. For example, you can choose whether your 
audience can copy text out of your PDF file to 
paste into another application. However, if you 
enable any of the security features, be sure to 
select the checkbox labeled Enable Text Access 
of Screen Reader Devices for the Visually 
Impaired (it is enabled by default).

Figure 8. The Export Adobe PDF dialog box

Working in Adobe Acrobat Pro
After opening your PDF file in Acrobat Pro, 
you will likely need to change one or two things 
before the PDF is considered fully accessible.

Document Language
The W3C Web Accessibility Guidelines pre-
scribe that you tag your documents with a 
specific language. InDesign does not have the 
ability to assign a document language to the 
PDF file, so you’ll need to do this in Acrobat. 
Choose File > Properties, click the Advanced 
tab, and choose from the Language pop-up 
menu. (Alternatively, if the language you want 
is not listed here, you can type it into the field.)

Remapping Tags
When you export a tagged PDF from InDesign, 
your paragraph styles become tag names in the 
PDF. For example, a paragraph style named 
“bodytext” will appear tagged as “bodytext” in 
the PDF. You can see these tags by choosing 
View > Navigation Panels > Tags. 

Tip: To view all the tags in a document, 
Option-click (Mac OS) or Alt-click (Windows) 
the “twist-down” triangle next to the Tags icon 
in the panel (Figure 9).
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Figure 9. The Tags panel in Acrobat Pro

Tip: When working with tags in Acrobat Pro, it 
is useful to choose Highlight Content from the 
Options menu in the Tags panel. When you do 
this, selecting a tag in the panel draws a light 
border around the text or object.

Although your text is tagged with the 
InDesign paragraph style name, Acrobat uses a 
feature called the Role Map to associate those 
style names with the proper PDF tags. You 
can see these mappings by choosing Edit Role 
Map from the Options menu in the Tags panel 
(Figure 10). 

InDesign creates the Role Map in the PDF 
file based on the settings you used in the Map 
Styles to Tags dialog box. For example, if you 
used Map Styles to Tags to map a style called 
“A-head” to the “H1” tag, the Role Map will 
display this.

Unfortunately, InDesign sometimes mis-
maps styles. Notably, if you used the Map Styles 
to Tags dialog box to map a paragraph style 

Figure 10. The Role Map lists your InDesign 
paragraph styles and the PDF tag each style is 
mapped to. Here, the paragraph style named 
“list” is mapped to a <P> tag. To change it to a 
<LI> tag, click the Change Item button.

called “list” to the <LI> tag, that mapping 
is currently not reflected in the Role Map—
instead, it’s mapped to a <P> tag. Therefore, 
you must create these mappings manually in 
the Role Map dialog box.

To change the mapping, select the para-
graph style (in this case, list) in the Role Map 
dialog box and click the Change Item button. 
Type in the name of the tag (in this case LI) 
and click OK.

Peruse the Role Map list and ensure that 
all paragraph styles are mapped to the PDF tag 
you expected.

Creating and Nesting Tags
You may also want to add additional elements 
in the Tags panel in Acrobat Pro. For example, 
in the case of a numbered or bulleted list, you 
should group (or “nest”) the list elements inside 
an <L> tag. InDesign cannot do this for you, 
even if you create this element in the Structure 
panel.
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The easiest way to do this is to select the 
last list element (by clicking on it in the Tags 
panel), then choose New Tag from the Options 
menu in the Tags panel. Type the name of the 
tag into the New Tag dialog box (in this case 
type the letter L) and click OK; Acrobat Pro 
creates the new tag after the selected element—
that is, at the end of the list.

Now, click on the first list element in the 
Tags panel and Shift-click on the last item in 
the list (to select the entire list), and then drag 
the selection over the new <L> tag element. 
When you see a short, thin, black line directly 
beneath the <L>, let go of the mouse button. 
This nests the list elements into your new tag 
(Figure 11).

Figure 11. Left: Six paragraphs set to a style 
named “bulletList” (which has been mapped to 
the <LI> tag in the Role Map). Right: After a 
new <L> element is created, you can drag the list 
items into it so that they are nested.

Reassigning Tags
In some cases, you may want to edit the tag 
applied to an element in your document. A 
case in point: table headings. While InDesign 
applies the <TR> tags properly for each table 
row in exported PDF files, it does not currently 
assign the <TH> tag to table headings. Instead, 
it assigns <TD>. 

Fortunately, you can reassign each of these 
tags easily in Acrobat. First, select a <TD> tag 
that you wish to change, then choose Properties 
from the Options menu in the Tags panel in 
Acrobat. (You can also right-click, or Control-
click with a one-button mouse, and pick Prop-
erties from the contextual menu.)

In the Tag tab of the TouchUp Properties 
dialog box, change the Type pop-up menu from 
Table Data Cell to Table Header Cell. Now 
repeat with the other mistagged table header 
cells. Note that you do not need to click the 
Close button in the TouchUp Properties dialog 
box until you have finished changing the tags. 

Document Order
Although you have already specified the appro-
priate reading order in the Structure pane in 
InDesign, you should also specify the tabbing 
order for each page of your document in Acro-
bat. Open the Pages panel in Acrobat (View > 
Navigation Panels > Pages) and select all the 
pages in your document (click on the first page, 
then Shift-click on the last page). Right-click on 
any of the selected pages (or Control-click with 
a one-button mouse) and choose Page Proper-
ties from the Context menu. In the Tab Order 
tab of the Page Properties dialog box, choose 
Use Document Structure.

After you click OK, try one or more of the 
following to ensure your document is set up 
with the proper reading order:

 » In Acrobat, choose View > Zoom > Reflow 
(or press Command+4 on the Mac OS or 
Ctrl+4 in Windows) to see how your docu-
ment would be viewed without regard to 
page layout and positioning—for example on 
some mobile devices. Page items tagged with 
Artifact disappear in Reflow mode, so this 
is a good opportunity to see if you forgot to 
apply that tag to one or more objects on your 
pages. 

 » Open the Order panel in Acrobat (View > 
Navigation Panels > Order) to confirm the 
reading order is correct for each page.
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 » Choose from the File > Read Out Loud 
menu to hear a voice synthesizer read the 
document to you. This approximates what a 
screen reader user would encounter.

 » Check the document with third-party screen 
reader software, such as Freedom Scientific’s 
JAWS for Windows.

 » Choose File > Export > Text > Text (Acces-
sible) to save a text-only version of the docu-
ment. Opening that text file lets you see your 
document at its most basic, as readers using 
a Braille printer would experience it.

Accessibility Check
At this point, it is a good idea to run an 
accessibility check in Acrobat. First, save the 
document, and then choose Advanced > Acces-
sibility > Full Check. (Acrobat also offers an 
option for a Quick Check, but it’s worth taking 
the time for the full check.) The Name pop-up 
menu in the Accessibility Full Check dialog 
box offers several different ways to check your 
document. The Adobe PDF option is likely 
good enough for most of your documents.

After you run the Full Check, Acrobat dis-
plays its findings in the Accessibility Report tab 
in the left panel. If any errors were found, the 
report will offer suggestions for how you can 
repair the problems. 

However, note that some found errors 
may not actually affect the readability of the 
document, and not all document errors will 
be flagged by the Full Check. For example, the 
Full Check cannot alert you if a paragraph has 
the wrong tag, or the document has the wrong 
reading order—because only you, the content 
creator, can know what is right and wrong for 
your document.

Ultimately, if you follow the techniques 
outlined in this document, you should be able 
to create accessible documents with few to no 
errors efficiently.

Resources
You can find additional information about 
accessible PDF files at these websites:

 » Adobe.com/accessibility

 » www.adobe.com/accessibility/products/
indesign/overview.html

 » Knowbility.org/main

 » Section508.gov

 » indesignsecrets.com/accessibilty

 » www.hhs.gov/web/policies/checklistpdf.html

 » www.planetpdf.com/enterprise/learningcenter.
asp?ContainerID=1505

 » www.webaim.org/techniques/acrobat/

http://adobe.com/accessibility
http://www.adobe.com/accessibility/products/indesign/overview.html
http://www.adobe.com/accessibility/products/indesign/overview.html
http://knowbility.org/main
http://section508.gov
http://indesignsecrets.com/accessibilty
http://www.hhs.gov/web/policies/checklistpdf.html
http://www.planetpdf.com/enterprise/learningcenter.asp?ContainerID=1505
http://www.planetpdf.com/enterprise/learningcenter.asp?ContainerID=1505
http://www.webaim.org/techniques/acrobat/
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